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Overview 
 

Learn how to build and run a mobile canvassing (walk) list.  This tutorial covers all of the steps to create a canvassing Script, create user accounts 

for your canvassers, assign the list voters/contacts to your users (canvassers), and how to use the Android and iPhone apps in the field.  The final 

section shows how to build reports (formats) to analyze the canvassing results in your Trail Blazer database.  Learn more about the canvassing apps 

by watching this video. 

 

 

 

 

 

http://www.trailblz.com/kb
https://play.google.com/store/apps/details?id=com.trailblz.basecamp
https://itunes.apple.com/us/app/trail-blazer-basecamp/id1219460381?mt=8
https://www.youtube.com/watch?v=wzpATLcIK44
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Outline 
1. Creating Canvassing Questions (Script) 

2. Creating New Canvassers (DB Users with Access to the Mobile Apps) 

3. Build a Targeted List of Voters/Contacts to Canvass and Assign the List (and Script) to your Canvassers 

4. Using the Trail Blazer Basecamp App to Canvass Voters/Households 

5. Build a Format to Analyze the Canvassing Results 

6. Related Resources 

 

 

Tip: Take advantage of our Turf Cutting tools to build targeted door-knocking lists off of an interactive map.  Watch this video to learn how.  

Here’s an example: 

 

http://www.trailblz.com/kb
https://www.youtube.com/watch?v=TTGEihGDZwU
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1. Creating Canvassing Questions (Script) 
 

First, you’ll need to create the canvassing questions (script) that your door-knockers will be asking.  These questions are powered by the attribute 

system.  With some of the recent updates the mobile app in 2018, you’re now *required* to create sub-folders for each section of canvassing 

questions (attribute items). 

 

Navigate to the Voters list > Attributes tab. 

 

http://www.trailblz.com/kb
https://trailblz.com/kb/?action=view&kb=182&cat=0&qq=attribute
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Right-click on the Attributes folder and select Insert folder… 

 

 
 

Give the folder a name, and then click [OK].  The name of the attribute folder will be the name of your canvassing script, my example is below. 
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Next you’ll need to create sub-folders to place your canvassing questions (attribute items) into.  Right-click on your new primary folder and select 

Insert folder… 
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Give your attribute sub-folder a name and click [OK].  The name you give the folder is what will show up as the ‘canvassing question’ on the mobile 

app.  My example is below. 
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Now you can begin entering the answers (attribute items) to the questions (attribute sub-folders), that your canvassers will be asking.  If you need 

to answer multiple answer options, check the box that says ‘keep this form open’.  Click [OK] after entering each “answer”.  My examples are 

below. 
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Once you’re finished entering the canvassing questions for a particular question, click [Cancel] to close out of the expanded window. 

 

 
 

Repeat the above steps until all attribute questions and answers have been entered below the primary ‘canvassing script’ folder.  My finished 

example is below. 
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The final steps for creating the canvassing script is to right-click on the primary (parent) folder and select Properties. 
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Check the box for ‘This attribute folder contains a script for the mobile canvassing application.’ and then click [Save]. 
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You can modify this canvassing script as much as you need in the future by adding new questions, sections, renaming items, etc. 
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2. Creating New Canvassers (DB Users with Access to the Mobile Apps) 

 

Important Note: you can have as many users setup with access to your Trail Blazer database, and the mobile apps.  It’s important to make sure 

these users don’t have more access than needed.  This section shows how to setup a new user with only enough access to log into the mobile 

canvassing app, and use it to canvass voters that are assigned to them. 

 

Navigate to the Voters list. 
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Run a search for the person you want to setup as a new user.  If they’re in your database already, open their contact record card, if they aren’t, 

click [+ New] at the top to create a new record.  In this example I searched for someone (Tina Funkle) who wasn’t in my database, and added them 

as a new record. 
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If you’re adding a new person to the database, fill out the relevant information and then click [OK].  If you’re using an existing contact record, you 

can move on to the next step. 
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Navigate to the Admin tab > Logon sub-tab.  Check Allow Windows-based Access, create a User ID and Password for the canvasser, and [Save and 

Close]. 
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That’s all that’s required to give a user limited access for using the mobile app for canvassing.  You’ll need to restart Trail Blazer in order for the 

new user to display as an option when assigning your canvassing lists. 

 

 

 

 

 

 

 

3. Build a Targeted List of Voters/Contacts to Canvass and Assign the List (and Script) 

to your Canvassers 

 

As mentioned at the very beginning of this article, you have the option to build a canvassing list using our turf-cutting (mapping) tools if you’ve had 

your address data geocoded (which is an additional service).  Watch this video to learn how.  You can then pull up that list inside of the desktop 

CRM after creating it with Trail Blazer IQ, ex: 

 

http://www.trailblz.com/kb
https://www.trailblz.com/Support/AdditionalServices
https://www.youtube.com/watch?v=TTGEihGDZwU
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Otherwise, this section shows how to build the canvassing list using the voter/contact data that’s already in of your Trail Blazer database.  Both 

options are good and serve their own purpose.  Sometimes you may even want to use a combination of both tools to create a targeted list. 

 

Navigate to your Voters (Contacts) List. 
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Build and run your targeted search query for the list of voters that you want to canvass.  In my example I searched for all voters in precinct 30, 

which produced 110 results. 

 

http://www.trailblz.com/kb


Create and Run a Mobile Canvassing (Walk) List – Setting Up Users, 
Creating a Script, Etc. 

 

 KNOWLEDGE BASE www.trailblz.com/kb    30 

 
 

Once you have the list of voters generated, click File > Communications > Create Canvassing List… 
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Give your Canvassing List a name, select the Script to use (creating a script is covered in section #1), set the status to Open (if you want the list to 

be available immediately within the mobile app), and select which user(s) to assign it to.  My example is below. 
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After configuring your settings you’ll click [OK] to generate the canvassing list, and it will be assigned to the user(s) selected. 

 

The system will prompt you with a popup after it’s finished.  Click [OK] to finish. 
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The user(s) that you assigned the list to can now access it by logging into the Trail Blazer Mobile Basecamp app on their iOS or Android device, ex: 
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The next section walks through the steps on how to login and use the mobile canvassing app. 

 

 

 

 

 

 

 

4. Using the Trail Blazer Basecamp App to Canvass Voters/Households 

 

Download the Trail Blazer Basecamp app: 

- iOS: https://apps.apple.com/us/app/trail-blazer-basecamp/id1219460381 

- Android: https://play.google.com/store/apps/details?id=com.trailblz.basecamp 

 

Example of how the app will appear on the App Store (in my screenshot the app has already been downloaded / installed): 

 

http://www.trailblz.com/kb
https://apps.apple.com/us/app/trail-blazer-basecamp/id1219460381
https://play.google.com/store/apps/details?id=com.trailblz.basecamp
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Once the app is downloaded and installed, you can launch it by tapping on the app icon from the home screen of your device.  For this example I 

will be using the iOS version on an iPhone. 
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The first time that you login you’ll need to tap on the settings / gear icon in the lower-right in order to enter your Database Name. 
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On the Logon Credentials page, enter your Database Name (if you don’t know it you will need to contact your database Admin or Tech Support), 

and then enter your User ID and Password.  Tap Save once complete.  My example is below. 
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This will bring you back to the main login screen.  Tap on the Logon Base Camp button. 
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This will bring you the Dashboard screen.  Tap on Canvassing. 
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Select if you will be canvassing online (default) or offline (typically used in an area with spotty cell service or to save battery life).  Then tap on the 

Addresses button. 
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This will bring you to the full list of households / addresses that are part of the assigned canvassing list. 

 

http://www.trailblz.com/kb


Create and Run a Mobile Canvassing (Walk) List – Setting Up Users, 
Creating a Script, Etc. 

 

 KNOWLEDGE BASE www.trailblz.com/kb    52 

 

http://www.trailblz.com/kb


Create and Run a Mobile Canvassing (Walk) List – Setting Up Users, 
Creating a Script, Etc. 

 

 KNOWLEDGE BASE www.trailblz.com/kb    53 

 

You can type in an address at the top, or a partial address (such as a street name).  This will filter the list to display the results that match your 

search criteria.  In my example I searched by “Lake Street” which displayed 5 households to canvass. 
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Tap on a specific address in the list to open up that household to begin canvassing.  In my example I opened the household for “Thomas”. 
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Tip: you can tap on the address inside of the record to open the address on a map app and get directions.  Ex: 
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Note: if you open a household record that has more than one voter listed, you can canvass multiple people at the same time by selecting each 

name at the top of the record card. 

 

Work your way down the form and check off the answers to the questions.  My example is shown below in two pictures. 
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Finish answering the questions and add comments if applicable.  Tap on [Save] once complete. 
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The list of households will display a green or yellow icon next to the address to distinguish if the voters in that household have been partially or 

fully canvassed.  My example is below. 
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Repeat these steps until all voters have been canvassed. 

 

 

Tip: you can filter the canvassing list to show just the households that have been canvassed, not canvassed, or partially canvassed, by tapping on 

the menu icon in the top-right: 
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One other tip is that you can view a snapshot of how many voters have been canvassed and how many are left, by navigating to the Assignments 

section: 
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Continue on to the final section to learn how to analyze the canvassing results inside of your Trail Blazer database by building a format with 

attributes. 
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5. Build a Format (Report) to Analyze the Canvassing Results 

 

This section will show how to search by the canvassing results in your database and how to analyze the answers to the canvassing questions that 

are being collected.  There are a few different ways to analyze canvassing results inside of the database.  I walk through each of them below. 

 

Note: for an in-depth look at how to build these types of reports, this older KB article takes a deeper dive (this article uses the “older” paper walk list 

method but much of what is covered is still very relevant for data entry and reporting with canvassing results): 

https://www.trailblz.com/kb/?action=view&kb=192&cat=0&qq=walk 

 

First, log into your Trail Blazer database. 

 

You will start by going to the Canvassing list where you can view the overall stats by clicking the [Search] button (see below screenshot).  You can 

then click the canvassing description name to open up the list. 

 

http://www.trailblz.com/kb
https://www.trailblz.com/kb/?action=view&kb=192&cat=0&qq=walk


Create and Run a Mobile Canvassing (Walk) List – Setting Up Users, 
Creating a Script, Etc. 

 

 KNOWLEDGE BASE www.trailblz.com/kb    70 

 
 

The first tab will be Assignments.  The image below details all the different things you can from this tab, such as: 

- Adding / removing assignments 

- Change the list name 
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- Change the script 

- Update the status 
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Under the Voters tab you will be able to sort the list by the date / time that a voter was canvassed and also view / sort by who canvassed the 

voter.  The image below details this. 
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The last tab inside of the canvassing list record is the Addresses tab.  You can do virtually the same thing as the Voters tab from this section, but 

the data will display more in-depth information on the address records.  The image below details this further. 

 

 
 

Note: if you click on the name of the voter in the Voter tab you can view the voter’s attributes that they “answered” on the script.  See the two 

example screenshots below: 
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Under the Attributes tab inside of the voter’s record you can expand the attribute folder used for the canvassing script that you used, and view the 

results of the questions that were asked.  My example is below. 
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If you capture a comment / note via the mobile canvassing app, that note will display under the Logs tab > Logs sub-tab of the voter’s record.  

Example: 
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Moving on to the other way you can view canvassing results; navigate to the Voters list. 
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Navigate to the Canvass tab and ‘Plug’ it in to activate it for searching.  You can then run searches for voters that are part of specific canvassing 

lists, and filter further by their Canvass Processing status.  My example is below, where I searched for voters that were canvassed for the Precinct 

30 list.  So far there were two people processed. 
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Click Format > Columns… 

 

 
 

Navigate to the Attributes tab and expand [+] the folder that contains your canvassing script.  Check the boxes in the Settings column to add in the 

answers to the questions that you are asking.  My example is below. 
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Click [OK] to finish adding these questions/answers into the grid.  The columns will display on the far right by default (you can click-and-drag them 

left or right to rearrange them). 

 

 
 

http://www.trailblz.com/kb


Create and Run a Mobile Canvassing (Walk) List – Setting Up Users, 
Creating a Script, Etc. 

 

 KNOWLEDGE BASE www.trailblz.com/kb    85 

The answers to the questions your canvassers are checking off will tally at the bottom of each column (providing you with good insight into things 

like: what issues are people most interested in, do they support your candidate, do they want to volunteer, do they want a yard sign, etc.). 

 

To save the format (view) for future use, click Format > Save As… 

 

 
 

Give the format a name and click [Save]. 
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To access the saved Format (aka “view or report”) in the future, click Format > Select Saved… and load the format. 
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You can also assign the format as your default.  This article provides a deeper dive on how to build, save, and manipulate formats: 

https://www.trailblz.com/kb/?action=view&kb=272&cat=0&qq=format 

 

The related resources below provide some more information on how to cut turf and canvass using the Trail Blazer software. 
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Related Resources 
 

Article: How to Create Attribute Folders and Attribute Items (Custom Categories) 

Article: Walk List, Selectable Format – How to Create Paper Walk Lists with Questions and How to Enter the Results in ‘Batch Mode’ 

Article: Adding a New Database User and Setting their Security Settings 

Article: Creating and Saving Default Formats for Reporting with the Grid 

Video: Turf Cutting 

Video: Door to Door Canvassing Using iPhone or Android 

Video: Take Photo From Phone App 

Video: Trail Blazer Mobile App for Apple and Android 
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Trail Blazer Live Support 
 

  Phone:  1-866-909-8700 

   Email:  support@trailblz.com 

   Facebook: https://www.facebook.com/pages/Trail-Blazer-Software/64872951180 

   Twitter: https://twitter.com/trailblazersoft 

 

 

* As a policy we require that you have taken our intro training class before calling or emailing our live support team. 

 

Click here to view our calendar for upcoming classes and events.  You can sign up other members on your team for the same training. 

 

* After registering you’ll receive a confirmation email with the instructions for how to log into the GoToMeeting session where we host our live 

interactive training classes. 

 

* This service is included in your contract.  
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